Monday, February 9, 2015

Perforce eclipse error: Error occurred during the SSL handshake: invalid SSL session

How to fix the eclipse's perforce plugin error "Error occurred during the SSL handshake: invalid SSL session"

If you are getting the above error, it means your JVM and Perforce servers are not successfully exchanging SSL certificate. You have install JCE (Java Cryptography Extension) to make it work.

These are the steps to fix this issue:

Download JCE

If the above didn't work, search with the keywords "JCE Java 6" or "JCE Java 7" or "JCE Java 8" depending on the Java version you are using.

Backup existing libraries

Backup the following libraries available under the location "$JAVA_HOME/jre/lib/security" to a safe location. You have to overwritten these libraries in next step.
  • local_policy.jar
  • US_export_policy.jar

Copy libraries

The JCE package downloaded in step one would have two jars (local_policy.jar, US_export_policy.jar). Extract these two files to the location "$JAVA_HOME/jre/lib/security"

Restart Eclipse

Close your eclipse if it is already running. After restarting the eclipse, you should be able to successfully connect to perforce.

No comments: